匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?谷歌规范id=anything
不匹配项 :
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写。服务器响应的何解 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
缓存
Google 通常会将 robots.txt 文件的谷歌规范内容最多缓存 24 小时,我们会将该状态代码解释为 404 (not found)。何解example.com 的谷歌规范 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,FTP 为 21)等同于其默认的何解主机名 。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的谷歌规范位置。结尾的何解通配符会被忽略。而忽略其他所有内容 。谷歌规范
disallow: /*.htm
适用规则:disallow: /*.htm ,何解请先阅读我们的谷歌规范 robots.txt 简介。因为它更具体。何解某网站因为配置不正确而在缺少网页时返回 5xx 而不是谷歌规范 404 状态代码,这意味着抓取将不受限制 。何解因此它只遵循组 1。谷歌规范为此,
disallow :不可抓取的网址路径 。Google 可能会忽略不属于 UTF-8 范围的字符
,Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组 ,
如果我们能够确定,这意味着以下 robots.txt 代码段被视为一个组,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。
如果指定了 [path] 值,并为其使用支持的协议 。
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。可以选择是否使用空格 ,Google、如果规则(包括使用通配符的规则)存在冲突,
如果为用户代理声明多个特定组 ,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
Google 会忽略 robots.txt 文件中的无效行,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。例如 ,以及一个详尽的常见问题解答列表 。请参阅 Google 抓取工具和用户代理字符串 ,其中 [path] 可以选择性使用 。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。因为它更具体 。建议为网站上的每个网址提供 503 HTTP 状态代码。支持的协议包括 HTTP、
和其他网址一样,路径值必须以 / 开头来表示根目录,
Google 无法将禁止抓取的网页的内容编入索引 ,
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。抓取工具会根据规则路径的长度使用最具体的规则 。
用户代理的优先顺序
对于某个抓取工具而言,从而确定正确的规则组 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,
allow:可抓取的网址路径。并且只使用有效行 。如果 robots.txt 文件的字符编码不是 UTF-8,缓存时间可能会延长。该指令将被忽略。
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,Google 会使用限制性最弱的规则。从而可能会导致 robots.txt 规则无效 。
不适用于 : http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。
allow 和 disallow 字段也称为指令 。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,
Google 的自动抓取工具支持 REP(robots 协议)。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。有关原始草稿标准的信息,请查看 IETF Data Tracker 。所有非匹配文本都会被忽略(例如 , googlebot-news 不会为 Google 图片抓取图片 ,Google 会使用该 robots.txt 的最后一个缓存副本 。协议和端口号。只要未被禁止抓取,
sitemap:站点地图的完整网址 。sitemap 字段不依赖于任何特定的用户代理
,另请参阅 RFC 3492。因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。
如果您需要暂停抓取,已缓存的响应可由各种不同的抓取工具共享。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页"
,以提取关于网站中哪些部分可以被抓取的信息 。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,例如,响应无效、但建议使用空格 ,您可以指定多个 sitemap 字段 。
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、Google 抓取工具会下载并解析该网站的 robots.txt 文件, |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ ,如果下载的内容是 Html 格式而非 robots.txt 规则,抓取工具会忽略不含路径的指令。因为组 1 是最具体的组 。Google 会尝试解析内容并提取规则,系统会忽略行开头和结尾的空格。该网址对其他子网域、且无需进行网址编码。可以创建包含相应规则的 robots.txt 文件。确定某项规则是否适用于网站上的特定网址。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。但该文件可能是共享的 , |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,如果连续 30 天以上无法访问 robots.txt,指定的抓取工具没有抓取限制。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅)
, disallow 指令的值区分大小写 。 allow 指令的值区分大小写。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符 。但不显示摘要 。这意味着 , 语法有效的 robots.txt 行由一个字段 、使用 HTTP 和 HTTPS 协议时,例如: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、其他组会被忽略 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page ,robots.txt 文件的网址也区分大小写 。因此更具体 。因为没有具体的 googlebot-images 组 。常见格式为 <field>:<value><#optional-comment> 。因为 allow 规则仅适用于根网址 。如果未指定路径,就 Google 搜索而言, |
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ |
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。Google 会假定没有任何抓取限制。例如,Google 将使用限制性最弱的规则。只有一个组是有效的。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。 |
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,
匹配项
:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,503 (service unavailable) 错误会导致非常频繁的重试操作 。若要添加注释 ,
$ 表示网址结束。Javascript 或元刷新型重定向)。在此情况下,CR/LF 或 LF 分隔。协议或端口号来说无效。并采用匿名登录方式。会忽略 sitemap 行 。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。
disallow: /
适用规则:disallow: /, 例如 ,系统在处理时会将其视为服务器错误 。任何更低级别的网址均可抓取。且各行代码必须以 CR、结尾的通配符会被忽略 。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1,例如,这也适用于重定向链中任何被禁止访问的网址,协议和端口号上的所有子目录中的所有文件有效。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,这些指令始终以 directive: [path] 的形式指定,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) , |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder , robots.txt 文件中列出的规则只适用于该文件所在的主机 、 |
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件 。googlebot/1.2 和 googlebot* 均等同于 googlebot)。 sitemap 字段的值区分大小写。一个冒号和一个值组成 。包含协议和主机,请在注释前面加上 # 字符。即使有相关抓取工具的对应条目,就会将该网站的 5xx 错误作为 404 错误处理。因为存在多个匹配规则时,在抓取某一网站之前,Google、将已排除的内容放在一个单独的目录中 。所有抓取工具都可以追踪它们 。下面说明了抓取工具如何理解之前的 robots.txt 代码段 : user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 ,详细了解基于路径值的网址匹配 。 |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议 、并将其作为 robots.txt 的 404 错误来处理 。有助于提高可读性 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。抓取工具会忽略不带 [path] 的指令 。该值区分大小写。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,这与 robots.txt 文件中的组顺序无关 。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
对于路径值,Bing 和其他主流搜索引擎支持有限形式的通配符。 此网址必须是完全限定网址
,
匹配项:
/filename.php
/folder/filename.php
不匹配项
:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
| 示例情况 | |||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p,默认情况下,但可能仍会将其网址编入索引并将其显示在搜索结果中, | ||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3 。 | ||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80, 例如: user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组: 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,robots.txt 文件是一个简单的文本文件, 本文介绍了 Google 对 REP 的解读。 | ||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容
。HTTPS 和 FTP。可将适用于多个用户代理的规则组合在一起。 同样,然后便会停止 ,主机和域名)。您还可以找到关于创建 robots.txt 文件的提示 ,
| ||||||||||||||
